Version Python pour opentf-tools trop récente

armour
Messages : 5
Inscription : jeu. janv. 27, 2022 10:42 am

Version Python pour opentf-tools trop récente

Message par armour »

Bonjour,

Je souhaite utiliser opentf-tools dans nos projets pour lancer des workflows. Le problème provient de la version très récente de Python demandée pour l'installation d'opentf-tools. Nous utilisons la version 18.04 d'Ubuntu qui propose dans le repo officiel la version 3.6 de Python alors qu'il faut la version 3.8 pour opentf-tools. Cela nous oblige à utiliser une version non présente dans les paquets.

De plus nos programmes Python utilisent certains paquets dont les versions sont incompatibles avec l'installation d'opentf-tools.

N'est-il pas préférable de proposer également une version "standalone" créée avec PyInstaller par exemple ? Cela devrait résoudre le problème de compatibilité.
lmazure
Messages : 3
Inscription : ven. janv. 14, 2022 2:09 pm

Re: Version Python pour opentf-tools trop récente

Message par lmazure »

Cette discussion est déplacée dans https://gitlab.com/opentestfactory/tools/-/issues/35.
Répondre

Revenir à « Squash DEVOPS »