Planification précise du support de Java + intégration de Tomacat ?

jvuibert
Messages : 21
Inscription : mar. janv. 24, 2017 3:04 pm

Planification précise du support de Java + intégration de Tomacat ?

Message par jvuibert » mar. janv. 24, 2017 5:21 pm

Bonjour,
Comme il semblerait que l'équipe soit de langue française, je vais poster ma demande dans cette langue.
De plus en plus d'entreprise demande à ce que les logiciels déployés au sein de leur entreprise soient à jour, pour des raisons de sécurité que l'on comprend aisément.
Depuis janvier 2015 (soit depuis 2 ans), il n'y a plus de maintenance publique de Java 7, dernière version supportée par Squash.
Pourrions-nous avoir une planification précise du support de Java 8 par Squash ?
De même, ne serait-il pas plus judicieux, toujours dans cette optique de maintien de la sécurité, d'avoir le serveur Tomcat en dehors de Squash ?
En vous remerciant d'avance de la prise en compte de cet aspect et de vos réponses.

mdelobeau
Messages : 256
Inscription : lun. avr. 18, 2016 8:53 am

Planification précise du support de Java + intégration de Tomacat ?

Message par mdelobeau » ven. févr. 24, 2017 9:46 am

Bonjour,

Squash TM fonctionne avec JAVA 8 à partir de la version 1.13.

Il est également possible de déployer Squash sur un serveur tomcat autre que celui embarqué.
Vous pouvez consulter notre wiki pour plus d'informations.

Cordialement,

Marion - Equipe Squash

jvuibert
Messages : 21
Inscription : mar. janv. 24, 2017 3:04 pm

Planification précise du support de Java + intégration de Tomacat ?

Message par jvuibert » ven. févr. 24, 2017 11:23 am

Je suis désolé mais dans le wiki que vous m'indiqué, on lit clairement :

Virtual Machine : JVM 1.7

https://sites.google.com/a/henix.fr/wiki-squash-tm/installation-and-exploitation-guide/1---system-requirements-and-prerequisites

Il serait alors souhaitable de le corriger en indiquant

Virtual Machine : JVM 1.7 minimum

ou, comme la JVM 1.9 va bientôt arriver

Virtual Machine : JVM 1.7 ou JVM 1.8

Cependant, je vous remercie de votre réponse.

Cordialement

LAFARGUE
Messages : 7
Inscription : lun. mars 13, 2017 7:15 am

Planification précise du support de Java + intégration de Tomacat ?

Message par LAFARGUE » mer. mai 10, 2017 3:06 pm

VUIBERT,

Chez nous, on tourne en JVM 1.8.0_121 sans aucun soucis sur une version Squash 1.15.4

Cordialement,

CLA

Karim
Messages : 102
Inscription : ven. avr. 20, 2018 6:51 am

Planification précise du support de Java + intégration de Tomacat ?

Message par Karim » ven. mai 04, 2018 5:32 pm

Bonjour,

Il est dorénavant clairement indiqué qu'il faut utiliser JVM 8 pour les versions de Squash TM à partir de la 1.17.

D'ailleurs, si ce n'est pas encore le cas, je vous invite à upgrader votre version de Squash vers la 1.17 et profiter ainsi des dernières améliorations apportées à notre outil.

Bonne journée à vous.

Cordialement.

Répondre