Erreur à la connexion Squash TM - Mantis

Marieno
Messages : 2
Inscription : ven. janv. 25, 2019 9:49 am

Erreur à la connexion Squash TM - Mantis

Message par Marieno »

Bonjour,

Je n'arrive pas à lancer Mantis depuis Squash, l'erreur obtenue est la suivante : une erreur est survenue: ; nested exception is : org.xml.sax.SAXParseException; lineNumber: 1 ; columnNumber : 1; Content is not allowed in prolog.

Voici les versions installées ; Mantis et Squash TM ne sont pas sur la même VM mais les 2 machines se voient bien.
Squash TM : 1.18.4
MantisBT : 2.19
PHP : 5.5.21
base de données : 5.6.43

Le paramétrage de l'url Mantis dans Squash TM est correct (http://machine_domaine/mantisbt).

J'ai vu qu'il pouvait y avoir une cause avec des fichiers utf8 enregistrés en BOM alors qu'il ne faut pas. Comment peut-on vérifier si on est dans ce cas, on parle de quels fichiers ?
Merci d'avance pour votre.

ppuiseux
Messages : 41
Inscription : ven. mars 30, 2018 12:53 pm

Erreur à la connexion Squash TM - Mantis

Message par ppuiseux »

Bonjour,

Mysql 5.6 n'est pas supporté par SquashTM.
Voici les pré-requis à respecter.

Autrement assurez-vous d'avoir bien installé le paquet PHP-SOAP sur votre serveur Mantis.

Cordialement,

Marieno
Messages : 2
Inscription : ven. janv. 25, 2019 9:49 am

Erreur à la connexion Squash TM - Mantis

Message par Marieno »

Bonjour

Merci pour votre réponse. La version 5.6.43 est la version de la base mantis. Est-ce que cela pose quand même un souci pour squash ?
Nous avons bien installé php-soap (5.5)

Avatar de l’utilisateur
Cedric190985
Messages : 67
Inscription : mer. avr. 04, 2012 8:46 am

Erreur à la connexion Squash TM - Mantis

Message par Cedric190985 »

Bonjour
Nous avons exactement la même erreur
Nos bases respectent les pré-requis

Avatar de l’utilisateur
Cedric190985
Messages : 67
Inscription : mer. avr. 04, 2012 8:46 am

Erreur à la connexion Squash TM - Mantis

Message par Cedric190985 »

Bonjour
J'ai installé Mantis 2.19
Est ce que cela vient de la version V2 de Mantis ?
J'ai lu dans le Wiki que Squash était compatible "1.2.15"
La version 2 n'est pas supporté ?
Merci

https://sites.google.com/a/henix.fr/wiki-squash-tm/installation-and-exploitation-guide/plugins-compatibility

ppuiseux
Messages : 41
Inscription : ven. mars 30, 2018 12:53 pm

Re: Erreur à la connexion Squash TM - Mantis

Message par ppuiseux »

Bonjour,

Votre Mantis est-il en HTTPS ?
Si oui il faudra importer son certificat dans la JVM de SquashTM.

L'erreur est-elle toujours identique ?
Avez-vous installé tous les paquets PHP (et redémarré Apache) nécessaires à Mantis ?

Autrement Squashtm est compatible avec Mantis version 2.x.

Répondre